phpMyAdmin 4.6.4 released with security fixes

phpMyAdmin 4.6.4 recently released, is a tool written in PHP intended to handle the administration of MySQL over the Web. Currently it can create and drop databases, create/drop/alter tables, delete/edit/add columns, execute any SQL statement, manage indexes on columns.

phpmyadmin-logo

phpMyAdmin 4.6.4 changelog

This release includes many security fixes of various levels of severity. Its recommended all users upgrade to this release immediately. For full information on the vulnerabilities fixed and mitigation factors for users who are unable to upgrade, refer to the ChangeLog file included with this release and the security announcements at https://www.phpmyadmin.net/security/

Aside from the security fixes, bugs have been fixed affecting:

  • Create view when no view name specified
  • Changing a password
  • Fix deleting of users with non-English locales
  • Fixed password change on MariaDB without auth plugin

How to Install phpMyAdmin 4.6.4 on Ubuntu 16.10 (Yakkety Yak), Ubuntu 16.04 (Xenial Xerus), Ubuntu 15.10 (Wily Werewolf), Ubuntu 15.04 (Vivid Vervet), Ubuntu 14.04 (Trusty Tahr), Ubuntu 12.04 (Precise)

sudo apt-get install mysql-server

sudo apt-add-repository ppa:nijel/phpmyadmin

sudo apt-get update

sudo apt-get upgrade

sudo apt-get install phpmyadmin
 
comments powered by Disqus