How to install VLC 2.2.4 Media Player on Ubuntu 16.04

VLC 2.2.4 “Weatherwax” released today by¬†VideoLAN development team is the fourth stable update to VLC’s 2.2 release series. This latest release¬†fixes a few bugs reported on VLC 2.2.3 for Windows XP and certain audio files. It also includes updated codecs libraries and fixes a security issue when playing specifically crafted QuickTime files as well as a 3rd party security issue in libmad.

vlc 223

VLC 2.2.4 Highlights

  • Fix crash in G.711 wav files
  • Fix mp3 crash in libmad
  • Fix out-of-bound write in adpcm QT IMA codec (CVE-2016-5108)
  • Fix overlay creation on Windows XP for DirectDraw video output
  • Improve compilation support for GNU/HURD
  • Minor UI improvements for the Qt interface on Windows, Linux, BSD

VLC 2.2.x Core Features

  • Auto-rotation of phone movies, to fight Vertical Video Syndrome
  • Resume playback where you left off
  • Extensions API and repository to download extensions directly from the application
  • GPU 0-copy support for decoding and displaying using hardware
  • Improved support for UltraHD codecs, notably H.265 and VP9
  • Subtitles download from the web, using OpenSubtitles
  • Audio core upgrade, notably to support short samples

Install VLC 2.2.4 on Ubuntu 16.04 and other Derivatives

Note: Reboot machine after install is completed for VLC to show in Dash

sudo apt-get build-dep vlc

wget -c download.videolan.org/pub/videolan/vlc/2.2.4/vlc-2.2.4.tar.xz

tar -xJvf vlc-2.2.4.tar.xz

cd vlc-2.2.4

./configure

make

sudo make install
 
comments powered by Disqus