Pidgin 2.11.0 Messenger App released, Install on Ubuntu 16.04

Pidgin 2.11.0 recently released, is a chat program which lets you log into accounts on multiple chat networks simultaneously. This means that you can be chatting with friends on MSN, talking to a friend on Google Talk, and sitting in a Yahoo chat room all at the same time. Pidgin runs on Windows, Linux, and other UNIX operating systems, and  it’s compatible with the following chat networks out of the box: AIM, ICQ, Google Talk, Jabber/XMPP, MSN Messenger, Yahoo!, Bonjour, Gadu-Gadu, IRC, Novell GroupWise Messenger, Lotus Sametime, SILC, SIMPLE, MXit, MySpaceIM, and Zephyr.

pidgin

Pidgin 2.11.0 update

  • General:
    • 2.10.12 was accidentally released with new additions to the API and should have been released as 2.11.0. Unfortunately, we did not catch the mistake until after 2.10.12 was released, but we’re fixing it now
    • Include the Mozilla certificate bundle. This fixes connecting to servers with certificates from Let’s Encrypt. Remove all 1024-bit CAs
  • libpurple:
    • media: fix an issue with ximagesink displaying only a corner cut-out of a larger webcam video
    • mediamanager: update output window destruction so that it reflects recent changes in the media pipeline structure
    • Ported Instantbird’s CommandUiOps to libpurple
  • Pidgin:
    • Fixed alignment of incoming right-to-left messages in protocols that don’t support rich text
    • Fix a potential crash while exiting pidgin
  • AIM:
    • Add support for the newer kerberos-based authentication of AIM 8.x
  • Windows-Specific Changes:
    • Use getaddrinfo for DNS to enable IPv6
    • Updates to dependencies: NSS 3.24 and NSPR 4.12.
    • Bonjour
    • Fixed building on Mac OSX
  • ICQ:
    • Stop truncating passwords to 8 characters like old ICQ clients did. If you actually needed this, truncate your password manually by pressing backspace a few times.
  • IRC:
    • Base64-decode SASL messages before passing to libsasl
  • MXit:
    • Fixed a buffer overflow
    • Fixed a remote out-of-bounds read
    • Fixed a remote out-of-band read
    • Fixed an invalid read
    • Fixed a remote buffer overflow vulnerability
    • Fixed an out-of-bounds read
    • Fixed a directory traversal issue
    • Fixed a remote denial of service vulnerability that could result in a null pointer dereference
    • Fixed a remote denial of service that could result in an out-of-bounds read
    • Fixed multiple remote buffer overflows
    • Fixed a remote NULL pointer dereference
    • Fixed a remote code execution issue
    • Fixed a remote denial of service vulnerability in contact mood handling
    • Fixed a remote out-of-bounds write vulnerability
    • Fix a remote out-of-bounds read

Compile Pidgin 2.11.0 on Ubuntu 16.04 since PPA is not updated to latest

sudo apt-get build-dep pidgin

wget 'https://sourceforge.net/projects/pidgin/files/Pidgin/2.11.0/pidgin-2.11.0.tar.bz2/download' --output-document=pidgin-2.11.0.tar.bz2

tar xjvf pidgin-2.11.0.tar.bz2

cd pidgin*

./configure

make

sudo make install

sudo ldconfig

pidgin
 
comments powered by Disqus